Введение

Данное Руководство описывает назначение, установку, принципы построения и способы применения программно-аппаратного комплекса Unit Bell, предназначенного для организации системы оповещения и предоставления других информационных услуг абонентам телефонной сети.

Будет рассказано как установить пакет, подключить и настроить линии связи с АТС, создать и запустить задачу, обработать и вывести результаты обзвона абонентов.

В документе представлено описание версии 1.0. Последние изменения, не нашедшие своего отражения в Руководстве и не выходящие за рамки текущей версии, оформляются отдельным приложением.


Назначение

Программно-аппаратный комплекс Unit Bell разработан и применяется для

· оповещения абонентов телефонной сети о задолженности за услуги электросвязи и предполагаемом времени отключения телефона в случае неуплаты

· информирование населения о готовящихся мероприятиях (например, в целях гражданской обороны), проведении митингов, концертов, выборов

· доведения до работников предприятий необходимой информации (о распорядке дня, организационно-штатных изменения, тревоге, аварии и пр.) и получения необходимых подтверждений

· организации службы доступа абонента телефонной сети к балансу своего счета, а также получения по введенному паролю конфиденциальной информации

· создания службы "точного времени"

· рассылки по подписке информации рекламного и иного (сказки, анекдоты, поговорки, пословицы и пр.) характера

· проведения телеголосований

Назначение комплекса не исчерпывается представленными здесь примерами использования и может быть существенно расширено пользователем за счет создания новых голосовых фраз и включения их в сценарии функционирования системы Unit Bell.


Терминология и сокращения

В Руководстве используются следующие принятые термины и понятия. В случаях объяснения пользовательского интерфейса будут применяться устоявшиеся термины среды Windows.

Далее приведен список часто используемых понятий:

Абонент - физическое или юридическое лицо, представленное записью в базе данных и однозначно определяемое каким-либо признаком (например, номером телефона)

АТС - автоматическая телефонная станция

Выходная таблица - таблица с выходными данными по результатам работы комплекса

Голосовая фраза - единица голосовых данных, используемая для построения голосового сценария и характеризующаяся типом, наименованием и записанным на жесткий компьютера файлом с данными в определенном формате (как правило файлы с расширением ".WAV")

Задача - совокупность организованных определенным образом данных, используемых в качестве сценария для выполнения действий по обзвону абонентов и оказания других информационных услуг

ЛВС - локальная вычислительная сеть

Номер - набранная абонентом последовательность цифр (символов) на телефонном аппарате в процессе соединения

ОС - операционная система

Скрипт обработки - набор команд в стиле языка SQL для выборки данных для обработки или просмотра согласно желаемым критериям

СУБД - система управления базами данных

Отчет - выходной документ, в окне Генератора Отчетов и готовый к распечатке

ПО - программное обеспечение

Результирующая таблица - выходная таблица после применения какого-либо запроса или фильтра

Шаблон отчета - служит для подготовки выходных документов со специфическим форматированием данных


Состав комплекса

Комплекс оповещения Unit Bell состоит из программной и аппаратной частей.

В качестве аппаратной части используется плата компьютерной телефонии "Ольха-9" или ее "облегченный" вариант - Ольха-10. Эта плата устанавливается в системный блок компьютера в один из PCI-слотов и может обслуживать до 4 потоков E1. В зависимости от требований конкретного приложения плата может иметь такие опции как эхокомпенсация и компрессия звуковых данных.

Для построения системы Unit Bell рекомендуется использовать версию "Ольха-9P/Е/Е1" - платы "Ольха-9P/Е1" с эхокомпенсацией G.165 и компрессией G.71.

Программная часть комплекса включает в себя

· драйверы для платы компьютерной телефонии "Ольха-9"

· тестовую программу для платы "Ольха-9"

· документацию по установке и программированию платы "Ольха-9"

· систему управления базами данных Sybase SQL Anywhere Studio v7.0.3

· базу данных и программные модули комплекса Unit Bell

· руководство пользователя комплекса Unit Bell (настоящий документ)

В информационной базе данных комплекса Unit Bell хранятся данные по функциональным настройкам задач и команд, которые выполнят комплекс в процессе своего функционирования. там же сохранятся результаты работы системы.

По этим результатам впоследствии можно построить необходимые статистические отчеты для анализа проделанной работы и принятия решения о запуске новых задач и информационных служб.


Получение справочных сведений

Все справочные сведения в электронном виде собраны в файлах помощи (HTML Help,Win Word). Доступ к этим файлам осуществляется путем нажатия клавиши F1 в режиме работы соответствующего окна либо с помощью соответствующей программы.

Работа с файлом помощи может происходить в трех режимах: поиск необходимых сведений, используя список разделов справки; поиск сведений по списку глав справки; поиск по словам внутри файла помощи.


Системные требования

Для установки и надежного функционирования программно-аппаратного комплекса Unit Bell необходимо выполнить следующие требования к компьютерному и системному программному обеспечению.

Требования к компьютеру

Комплекс устанавливается на любой IBM-совместимый компьютер, имеющий:

· процессор Pentium (Celeron) с внутренней тактовой частотой от 333 МГц и выше
· объем оперативной памяти от 32 Мбайт (64 Мбайт для Windows NT/Win2000)
· жесткий диск объемом 3Гб и выше
· устройство CD-ROM для установки системы
· звуковую карту, микрофон и колонки( наушника) для прослушивания и записи голосовых фраз

Настоятельно рекомендуется подключать компьютер к сети питания через блок бесперебойного питания во избежание сбоев в работе компьютера из-за возможных помех и наводок в сети или неожиданного полного отключения питания.

Требования к операционной системе

Данная версия системы оповещения Unit Bell работает только под управлением операционной системы MS Windows 9x/NT 4.0/Me/2000.

Внимание! Версия Windows 95 должна быть не ниже 4.00.1111. Для того чтобы узнать, какая версия операционной системы установлена на Вашем компьютере, из меню Start Windows запустите Programs > MS-DOS Prompt. В появившемся окне наберите ver и нажмите клавишу Enter.
аппаратного


Установка и запуск комплекса

Программы пакета Unit Bell устанавливаются с помощью утилиты инсталляции. Все необходимые исполняемые файлы, компоненты баз данных и другие необходимые системные файлы по умолчанию полностью содержатся на дистрибутивном диске (CD_ROM).


Установка оборудования и программного обеспечения

Установка оборудования

Для подготовки комплекса Unit Bell к работе в первую очередь необходимо установить в PCI-слот компьютера плату компьютерной телефонии "Ольха-9" и правильно обжать интерфейсный кабель потока E1, соединяющий соответствующее гнездо платы с разъемом на АТС.

Подробное описание этого процесса можно найти в документации на плату "Ольха-9", поставляемой в составе комплекса.

Описание диска

На установочном диске находятся файлы и папки, необходимые для инсталляции. Последние изменения пакета, а также важные замечания по его установке содержатся в файле Readme.txt.

Установка программного обеспечения

Установка программного обеспечения включает в себя несколько этапов:

1. установка драйвера платы компьютерной телефонии "Ольха-9". Этот этап выполняется при определении операционной системой нового устройства - платы "Ольха-9" или при обновлении версии драйвера и осуществляется стандартным для данной процедуры образом. Драйвера находятся в папке Alder9\Drivers установочного диска соответственно каждому типу операционной системы. После завершения установки необходимо перезагрузить операционную систему.

2. копирование документации и тестовой программы для плат "Ольха-9". Необходимые файлы находятся в папках Alder9\DOC и Alder9\COMMON установочного диска.

3. установка системы управления базами данных Sybase SQL Anywhere Studio v7.0.3. Для выполнения этого этапа необходимо запустить программу SETUP.EXE из папки Sybase Anywhere Studio v7.0.1 установочного диска и далее следовать инструкциям программы инсталляции. По завершении установки необходимо перезагрузить операционную систему. Для установки обновлений СУБД до версии 7.0.3 необходимо провести инсталляцию пакета обновлений. Для этого следует запустить программу SETUP.EXE из папки SQL Anywhere 7.0.3 установочного диска и далее следовать инструкциям программы инсталляции. По завершении установки необходимо перезагрузить операционную систему.

4. установка системы оповещения Unit Bell. Этот завершающий этап инициализируется запуском программы SETUP.EXE из папки eBell установочного диска. Мастер инсталляции выполнит все необходимые действия по копированию системных файлов на компьютер пользователя и произведет соответствующие записи в реестр системы.

Все необходимые для работы комплекса Unit Bell программные модули и файлы сохраняются в папке X:\Unitel\eBell (если пользователь не выбрал другое), где X: - имя диска. Ниже приводится перечень и описание файлов пакета:

· eBellSrv.exe - серверный модуль, исполняющий информационные задачи. Это приложение работает в фоновом режиме на основании установленных для исполнения в базе данных задач. Управление задачами и серверным модулем осуществляется с помощью модуля eBell.exe.

· eBellSrv.ini - конфигурационный файл, содержащий настройки, необходимые для работы серверного модуля.

· eBell.exe - диалоговый модуль управления процессом оповещения абонентов и другими информационными задачами. Применяется для создания и редактирования заданий, создания голосового интерфейса, просмотра результатов оповещения и текущего состояния телефонных линий, построения отчетных документов.

· Connect.ini - конфигурационный файл, содержащий настройки, необходимые для работы управляющего модуля eBell.exe.

· a9r15pp2t.bin (и другие файлы с расширением BIN) - файлы загрузчика для разных типов сигнализаций. Описание файлов можно найти в документации на плату "Ольха-9Р".

· eBellSrv.log - файл журнала, содержащий трассировки работы серверного модуля согласно текущим установкам LOG-файла. Создается в процессе работы комплекса.

· папка SOUND - содержит звуковые файлы (*.WAV), используемые для построения голосового меню задач.

· папка REPORT - содержит шаблоны файлов отчетных документов.

· папка DB - содержит файл базы данных eBell.db и файл параметров запуска сервера БД eBell.cfg.


Настройка и запуск комплекса

После полной установки аппаратной и программной частей комплекс Unit Bell готов к работе. Если при инсталляции были выбраны папки, отличные от предлагаемых по умолчанию, может потребоваться корректировка некоторых параметров в файлах конфигурации (eBellSrv.ini и Connect.ini). Как это сделать объясняется в соответствующих разделах.

Сразу после установки комплекс готов к работе. Для этого необходимо загрузить сервер базы данных и сервер управления комплексом Unit Bell. Соответствующие "иконки" расположены на рабочем столе операционной системы. Если на этот момент в базе данных имеются активные задачи, они начнут свои выполнение.

Для просмотра состояния задач и их корректировке необходимо загрузить диалоговый модуль управления eBell.exe. Этот модуль может исполняться на любом компьютере локальной вычислительной сети (ЛВС). Для соединения с сервером Unit Bell необходимо в настройках программы ввести верные параметры связи с eBellSrv.

После включения и загрузки компьютера сервер БД и сервер eBellSrv будут запущены автоматически.

Изначально в базе данных нет активных задач и настройки сервера eBellSrv выставлены по умолчанию. Поэтому сразу после завершения установки рекомендуется провести настройку параметров сервера, потоков и тайм-слотов в соответствии с установленной конфигурацией окружения (компьютера и АТС, к которой подключен комплекс Unit Bell). Порядок настройки подробно описан в разделе серверный модуль.

В любое время сценарий запуска программных модулей может быть изменен. Например, если Вам нет необходимости загружать программы при запуске системы удалите соответствующие записи в реестре системы. Для этого загрузите программный модуль REGEDIT.EXE (это можно сделать из меню "ПУСК"->"ВЫПОЛНИТЬ"), перейдите в секцию HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Run и удалите запись eBellSrv.exe. Теперь для запуска системы оповещения достаточно вручную загрузить на выполнение модуль eBellSrv.exe используя те же "иконки" рабочего стола ОС.


Работа с программным обеспечением

В данном разделе будут рассмотрены вопросы настройки, использования и обслуживания модулей и хранилищ данных, входящих в состав программного обеспечения комплекса Unit Bell.

Все программные модули представляют собой Windows-приложения и имеют многопоточную архитектуру.


Общие положения

Система оповещения Unit Bell обеспечивает выполнение следующих основных функций:

· формирование задач обзвона по списку абонентов, хранящемуся в любой стандартной базе данных с установленным для нее драйвером ODBC или JDBC;

· одновременный многоканальный обзвон абонентов по всем исходящим линиям в соответствии со сформированными задачами с автоматической регистрацией результата каждой попытки;

· формирование входящих задач для линий, отвечающих на звонки абонентов;

· формирование шаблонов задач, на основе которых производится формирование входящих задач и задач обзвона;

· просмотр списка задач, а также результатов выполнения каждой задачи, вывод на печать результатов выполнения задач обзвона;

· предоставление информации о последних звонках по всем входящим и исходящим линиям, информации о состоянии каждой линии;

· фиксирование всех ошибок и внештатных ситуаций при работе системы, полная трассировка событий, происходящих в системе.

Линии в системе могут быть трех типов: входящие, исходящие и универсальные (входяще/исходящие).

Входящие - линии, которые используются для обслуживания поступающих звонков в соответствии со сформированными входящими задачами.

Исходящие - это те линии, по которым осуществляется обзвон абонентов в соответствии со сформированными задачами обзвона.

Установка типа линии производится при настройке параметров серверного модуля eBellSrv (см. Потоки).

Чтобы линии заработали нужным образом, т.е. входящие отвечали на звонки, а исходящие дозванивались до абонентов, необходимо сформировать возможные сценарии работы системы, т.е. сформировать задачи обзвона и входящие задачи. Подробнее об этом написано в разделе Работа с задачами.

Внимание: входящая линия не будет отвечать на звонки, если в данный момент не существует ни одной активной входящей.

Редактирование и ввод новых задач, а также формирование отчетных документов можно выполнять автономно от аппаратной части комплекса, в том числе и не имея доступа к серверу ebellSrv.

Для того, чтобы иметь возможность контролировать процесс исполнения задач, диалоговый модуль ebell.exe должен иметь связь с сервером ebellSrv.

Если при старте приложения сервера драйвера плат не смогли быть запущены (по причине отсутствия плат или их некорректной установки), будет выдано сообщение об отсутствии линий в окне трассировки и записано в файл eBellSrv.log (если установлена соответствующие значения параметров журнала). В этом случае приложение не сможет осуществлять обзвон и отвечать на звонки абонентов (в тоже время просмотр результатов, печать и т.п. будут работать). Для запуска линий закройте приложение и установите платы или задайте корректно их настройки (см. Руководство пользователя по установке плат "Ольха-9Р").


Управляющий модуль

Для создания задач обзвона, входящих задач, мониторинга состояния каналов, просмотра результатов выполнения задач и вывода отчетных документов предназначен программный модуль eBell.exe. Внешний вид главного окна программы представлен на рисунке 1.

Рис.1. Главное окно управляющего модуля

Работа с функциями главного окна осуществляется через управляющие компоненты Windows. Это - меню, Toolbar, окна, деревья, списки и т.д. Некоторые окна построены таким образом, что они могут быть "отсоединены" от главного окна и располагаться на экране монитора независимо. К таким окнам можно отнести окно состояния задач, окно состояния потоков и тайм-слотов, окно статистики.

Состав и функции компонентов главного окна будут рассмотрены в следующих разделах.


Меню

Меню предназначено для доступа ко всем функциям управляющего модуля. Главное меню содержит пункты Настройки, Вид и Справка. Через них можно получить доступ к меню следующего уровня.

Пункт меню Настройки объединяет в себе еще три пункта:
· задачи

· фразы

· параметры

В меню Задачи собраны пункты доступа к функциям работы с задачами. К этим функциям можно получить доступ из функциональной линейки ToolBar, находясь в окне работы с задачами.

Меню Фразы открывает доступ к процедуре работы с голосовыми фразами. Здесь можно ввести фразу, отредактировать, прослушать звуковое содержание фразы.

Меню Параметры содержит окно диалога для ввода и редактирования текущих системных параметром модуля.

Пункт меню Вид предназначен для настройки внешнего вида главного окна и вызова на экран дополнительных окон модуля.

Через пункт меню Справка можно получить доступ к файлу справки по системе Unit Bell и информации о разработчиках и текущей версии системы.


Окно задач

Окно задач предназначено для просмотра текущего состояния, добавления, удаления и редактирования задач и шаблонов.

Рис. 2. Окно задач

Задача - это совокупность данных, используемых в качестве задания на проведение обзвона абонентов и приема входящих звонков. Данные хранятся в БД. Каждой задаче присваивается свое уникальное название.

В системе может быть две категории задач:

· шаблоны задач

· рабочие задачи

Шаблоны задач не могут быть исполнены системой и применяются для удобства создания на их базе рабочих задач.

Рабочие задачи непосредственно используются для выполнения информационных функций комплекса и могут быть откорректированы согласно конкретным требованиям независимо от исходного вида шаблона.

Задачи могут быть двух типов:

· входящие

· исходящие

Входящие задачи применяются только для поддержки входящих звонков. Одновременно их в системе может быть несколько. Конкретная входящая задача выбирается согласно номера доступа, по которому абонент дозванивается до системы.

Исходящие задачи применяются для оповещения абонентов согласно заданного списка. В текущий момент времени в системе может быть несколько активных задач, но из них только одна может быть текущей (выполняемой). Определение текущей задачи осуществляется на основе установленных для каждой задачи значений параметров. Для задач с одинаковыми значениями параметров текущей считается задача, которая была создана раньше.

Функции работы с задачами доступны либо через меню, либо напрямую посредством иконок, расположенных на панели ToolBar.

Для создания шаблона необходимо сначала создать задачу желаемого типа [image] - входящую или исходящую, установить значения параметров задачи и провести ее отладку на тестовом наборе данных. После этого задача может быть добавлена в папку шаблонов [image] и в дальнейшем использоваться для создания других задач.

Для того, чтобы создать задачу на базе имеющегося шаблона, необходимо выбрать шаблон и нажать кнопку [image]. После этого будет создана с параметрами шаблона. Затем следует отредактировать значения параметров задачи по своему усмотрению.

В папке шаблонов собраны шаблоны для обоих типов задач - входящих и исходящих. Иконка перед наименованием шаблона указывает на его тип: - исходящая, [image] - входящая.

Для исходящих задач в окне перед наименованием задачи отображается ее состояние. Если задача уже исполнена, она помечается [image]. Остановленные, но не исполненные помечаются [image]. Активные имеют вид [image]. Активные и текущие выполняемые - [image].

Таким образом, оператор всегда может оценить текущее состояние задач и отредактировать необходимые параметры.


Работа с задачами

Для управления задачами существуют определенные функции, доступные через систему меню (пункт Настройки->Задачи)

или посредством кнопок на инструментальной панели (ToolBar)

.

Назначение каждой кнопки становится понятным из меню.

Для создания новой задачи необходимо стать в папку задач согласно категории (входящие или исходящие ) и выбрать соответствующий пункт меню или кнопку на инструментальной панели. После этого на экран монитора будет выведено диалоговое окно, представленное ниже:

Рис. 3. Создание новой задачи

В этом окне собраны все параметры, влияющие на выполнение задачи.

Поле Активна определяет, включена ли данная задача или выключена. Если задача выключена, то она никогда не будет исполнена.

Наименование устанавливает для конкретной задачи ее название, по которому затем можно будет отслеживать результаты ее выполнения. Для исключения путаницы рекомендуется для каждой задачи использовать уникальное наименование.

Приоритет определяет уровень приоритета задачи. Это поле участвует в процедуре выбора текущей активной задачи. Чем приоритет выше, тем больше шансов у задачи быть выполненной.

Период выполнения задач по числам устанавливает временной промежуток выполнения задачи. Задача будет выполняться в пределах установленных дат и только в данном промежутке времени.

Переключатели Период выполнения задач по дням недели позволяют выбрать только те дни недели, в которые данная задача будет выполняться.

В случае, если дозвон до абонента завершился неудачно или по каким-либо причинам задача не была полностью завершена, попытка считается неудачной и будет повторена количество раз, установленных в поле Повторов через интервал, значение которого указано в поле Интервал (мин.).

Иногда может потребоваться подтвердить абоненту прослушивание сообщения. Для этого необходимо установить переключатель Подтверждение клавишей и из расположенного справа списка выбрать клавишу подтверждения.

Для того чтобы входящая задача заработала, необходимо ввести номер доступа, набрав который при дозвоне абонент выйдет на данную задачу.

Для получения списка абонентов для оповещения необходимо задать SQL-оператор, с помощью которого осуществляется доступ к необходимым таблицам базы данных. Данные по абонентам могут располагаться либо в таблице ABONENTS БД Unit Bell (в этом случае требуется импорт данных из корпоративной БД), либо в БД клиента, но в этом случае необходимо организовать доступ к данным через привлеченные (Proxy) таблицы используя установленные ODBC-драйверы и возможности СУБД Sybase SQL Anywhere Studio.

В данной версии программного обеспечения алгоритм работы с данными абонента ожидает, что в SQL-операторе на первом месте располагается номер телефона абонента, на втором - некоторая сумма денег, на третьем - дата/время. Необходимо обязательно соблюдать данный порядок следования полей!

Для того, чтобы проверить правильность SQL-оператора можно воспользоваться кнопкой Проверить. Если SQL-оператор составлен верно, на экран будет выведено окно с результатами запроса.

Когда все параметры выполнения задачи установлены, необходимо составить сценарий голосового обмена системы с абонентом. Для этого служит область, расположенная в правой части окна. Каждая строка содержит информацию только об одной фразе. Для управления фразами в верхней правой части окна находится инструментальная панель [image]. Создание новой фразы выполняется кнопкой [image], редактирование существующей - кнопкой [image], удаление - [image]. Для изменения порядка следования фраз применяются кнопки [image].

В системе установлены и обрабатываются семь типов фраз:

1. произвольная - задает фразу из базы данных

2. дата - только дата

3. время - только время

4. дата/время - дата и время

5. сумма - денежная сумма

6. число - любое целое число. Записывается в строке, имеет символы от 0 до 9 и проигрывается посимвольно

7. ввод пароля - эта фраза используется только для ожидания ввода строки символов, завершающихся символом, указанным в поле Подтверждение клавишей. Применяется только во входящих задачах. Голосовой фразы не содержит.

По окончании ввода всех значений, необходимо сохранить задачу, нажав кнопку "Да". Запись с данной задачей появится в соответствующем месте окна просмотра состояния задач.

Далее задача может быть использована в качестве шаблона. Для этого ее необходимо перенести в папку шаблонов используя кнопку [image].

Для редактирования задачи или шаблона достаточно нажать на кнопку [image] или дважды "щелкнуть" на соответствующей записи.

Для удаления записи о задаче или шаблоне применяется кнопка [image]. Следует помнить, что при удалении задачи вместе с ней будут удалены результаты ее работы и список фраз голосового сценария.

Для создания задачи на основе имеющегося шаблона достаточно воспользоваться кнопкой [image].

В процессе работы любая активная задача может быть выключена. В этом случае, если она в данный момент выполнялась, все текущие звонки будут остановлены и никакой информации по ним в БД сохранено не будет.

В то же время, если после включения задачи, она сразу переходит в разряд текущих исполняемых, сервер тут же начнет осуществлять дозвон до абонентов согласно списка.

Следует помнить, что исполненные задачи не могут быть повторно исполнены!


Результаты выполнения

Основная область главного окна модуля eBell отведена для вывода результатов выполнения задач. Все записи располагаются в хронометрическом порядке либо по возрастанию, либо по убыванию (задается нажатием на заголовок столбца Дата/время).

Рис. 4. Результаты выполнения задач

Каждая запись содержит описание результата попытки:
· сообщение доставлено
· нет подтверждения
· нет ответа
· занято [image],
дату и время попытки, номер телефона и наименование задачи.

Более подробную информацию по ходу и результатам выполнения задачи можно получить, воспользовавшись модулем статистики и построения отчетных документов (см. Отчеты).

Количество записей параметры вывода информации о результатах выполнения задач устанавливаются в через меню Настройки->Параметры или нажатием кнопки [image] на инструментальной панели главного окна модуля (см. Настройки).


Состояние каналов

В процессе работы комплекса в реальном режиме времени можно отслеживать состояния всех установленных в системе потоков E1 и тайм слотов. Эта возможность доступна только в том случае, если установлена связь управляющего модуля с сервером комплекса Unit Bell. Наличие связи с сервером индицируется на инструментальной панели специальной кнопкой. Если связь установлена кнопка имеет вид [image], в противном случае кнопка выглядит как [image] и нажатие на нее запустит процедуру поиска и установления соединения с серверным модулем.

Окно отображения состояния линий может располагаться на экране монитора обособленно, либо входить в состав главного окна. Оператор может сам настроить удобный для него сценарий поведения окна отображения состояния каналов.

Это окно имеет две области. В первой расположено дерево, отображающее наличие в системе плат компьютерной телефонии "Ольха" и установленных на них цифровых потоков E1.

Вторая область содержит информацию о тайм-слотах выбранного для мониторинга потока. Каждый тайм-слот имеет свой номер, он может быть включен или выключен, о чем свидетельствует "лампочка", следующая за номером тайм-слота. Тип тайм-слота отображается пиктограммой:

· для исходящего

· для входящего

· для входяще/входящего

Направление установления соединения также отображается соответствующими пиктограммами:
- для исходящего соединения.

Далее следует номер телефона абонента и наименование исполняемой на данном канале задачи.


Отчеты

Для обработки и анализа результатов выполнения задач, а также построения и выдаче на печать отчетных документов применяется модуль статистки.

Этот модуль встроен внутрь управляющего модуля и может быть вызван на исполнение с помощью пункта меню Вид->Панели->Статистика. Окно модуля статистики может располагаться как обособленно, так и в составе главного окна.

Рис. 5. Окно модуля статистики

С помощью этого модуля можно строить и выводить на печать отчеты на основе подготовленных ранее шаблонов, добавлять новые шаблоны, редактировать или удалять существующие.

Управление модулем статистики осуществляется посредством инструментальной панели
.

- используется для построения и просмотра отчета. Нажав на расположенную справа стрелку можно получить историю работы с модулем.

- служит для вывода отчета на печатающее устройство. Предварительно необходимо установить в системе хотя бы один принтер и назначить его устройством по умолчанию.

- создает новый шаблон и вызывает на исполнение модуль построения отчета.

- используется для редактирования существующего шаблона.

- создает новую папку шаблонов.

- позволяет переименовать существующую папку шаблонов.

- удаляет папку или шаблон.

- импортирует готовые шаблоны из директории шаблонов.

Все шаблоны отчетов могут быть сгруппированы в папки по какому-либо признаку. Для этого с помощью имеющихся инструментальных средств необходимо создать папку и поместить туда шаблоны отчетов.

При поставке комплекса Unit Bell в состав модуля статистики входит несколько общих шаблонов отчетов. Для их редактирования, расширения или создания новых шаблонов пользователь программной системы может самостоятельно освоить принципы построения шаблонов и добавлять их в соответствии со своими потребностями. Руководство пользователя редактором шаблонов отчетов входит в состав стандартной поставки ПО комплекса Unit Bell.


Сервис

Сервисные функции необходимы для установки параметров модуля и облегчения эксплуатации системы. К таким функциям относятся настройки модуля и функции работы с голосовыми фразами.

Настройки
Ввод фраз


Настройки

Необходимые для работы управляющего модуля значения параметров сведены в окно диалога, который можно вызвать на выполнение посредством меню Настройки->Параметры.

Рис. 5. Настройки управляющего модуля

Секция Журнал обзвона определяет параметры вывода на экран монитора и обновления информации по результатам работы комплекса.

Журнал может обновляться либо по команде от сервера eBellSrv, либо по таймеру. В последнем случае необходимо установить переключатель Таймер и выставить интервал обновления данных (в секундах). Следует помнить, что слишком малый интервал может привести к излишней нагрузке в работе системы, так как модуль будет постоянно опрашивать БД на появление в ней новых записей.

Длина журнала устанавливает количество выводимых на экран записей результатов работы системы. Если нет необходимости не устанавливайте слишком большое значение этого параметра!

Секция Адрес сервера определяет IP-адрес и порт сервера eBellSrv. Если эти параметры заданы верно и сервер загружен на указанном компьютере локальной сети, с ним будет установлена связь.

Секция Путь устанавливает путь к папке, содержащей звуковые файлы, использующиеся при построении голосового сценария.


Ввод фраз

Для управления фразами, использующимися при построении голосовых сценариев, существует пункт меню Настройки->Фразы. При его выборе на экран монитора выводится окно диалога, представленное на рисунке 6.

Рис. 6. Управление голосовыми фразами

Используя этот диалог, можно просмотреть установленные в БД фразы, добавить новые или удалить старые, изменить название фразы, а также прослушать ее звучание через динамики компьютера.

Для каждой фразы имеется ссылка на имя файла, содержащего звуковые информацию фразы (см. Описание БД).


Серверный модуль

Для непосредственного выполнения подготовленных ранее управляющим модулем eBell задач предназначен серверный модуль eBellSrv.

Этот модуль может быть загружен автоматически вместе со стартом операционной системы или же вручную из каталога, куда он был установлен программой инсталляции. Во время старта модуль проверяет загружен ли сервер БД и, если нет, то загружает его в соответствии со строкой запуска, прописанной в файле конфигурации eBellSrv.ini в секции DbConStr раздела [SYSTEM] (см. Общие).

Далее проверяется присутствие драйвера платы компьютерной телефонии "Ольха-9Р" в системе. При его отсутствии или ошибке при инициализации платы программный модуль прекращает свою работу. Если загрузка платы прошла успешно, далее производится распределение памяти под управляющие структуры и инициализация необходимых параметров согласно значениям, установленным в конфигурационном файле eBellSrv.ini. Подробное описание параметров будет дано ниже.

После загрузки сервер сразу начинает просматривать записи БД, относящиеся к установленным задачам, и выбирать из них активную на основании текущих значений параметров. Далее по всем доступным на данный момент каналам производится дозвон до абонентов согласно сформированного на основании SQL-запроса списка, выполнения голосового сценария и сохранения результатов обзвона.

Для входящих задач при наличии свободных входящих линий выбирается подходящая согласно значений параметров входящего звонка задача и далее алгоритм действий модуля аналогичен вышеописанному.

Свое название "серверный" модуль eBellSrv получил благодаря возможности подключать к себе для управления несколько управляющих модулей eBell (используя IP-протокол) и распределять между ними ресурсы. Таким образом, можно получить доступ к текущему состоянию процесса оповещения из любого места локальной сети, в том числе и через Internet.


Управление

Сразу после запуска серверного модуля в правой нижней части экрана появляется иконка, отображающая процесс запуска сервера.

startsrv1
старт сервера

Если запустить модуль по каким-либо причинам не удастся, программа будет выгружена из памяти, а иконка - удалена из SysTray.
В противном случае иконка примет вид, показанный на рисунке [image]. Это означает, что все ресурсы и службы были запущены и необходимые структуры проинициализированы, после чего можно начинать работу.

В штатном режиме работы серверного модуля он запускается без внешнего интерфейса и не требует какого-либо управления. Всю необходимую для работы информацию модуль берет из базы данных, а стартовые значения параметров - из файла конфигурации eBellSrv.ini.

В процессе работы модуля некоторые значения параметров конфигурации модуля могут быть изменены через специальное окно настройки. Вызвать это окно можно либо дважды "щелкнув" мышью на иконке сервера, либо, нажав на ней правой клавишей и выбрав пункт Свойства. На экран будет выведено окно диалога, показанное на рисунке 7.

Рис.7. Настройка параметров сервера

В данном окне представлены параметры, изменение значений которых может понадобиться в ходе работы сервера, без его полной остановки. В основном это касается установок журнала.

В процессе работы модуля все трассировки могут выводиться на экран и в файл. Соответствующие параметры в секции Направление вывода LOG устанавливают это направление. Следует помнить, что печать данных журнала необходима только в процессе отладки и поиска неисправностей. В штатном режиме работы модуля использовать эту возможность не рекомендуется, так как вывод дополнительного потока данных на экран (консоль) и в файл может приводить к замедлениям и потере эффективности в работе сервера, особенно при значительных размерах LOG-файла. Если Направление вывода LOG установлено "В файл", то будет создан для записи данных файл журнала eBellSrv.log.

Все сообщения имеют три уровня:

1. сообщения

2. предупреждения

3. ошибки

Установка или сброс вывода соответствующей категории выполняется в секции Категория сообщений LOG.

Секция Уровень сообщений LOG позволяет выбрать для вывода сообщения только от определенных объектов модуля. В программе сервера версии 1.0 используются объекты только следующих типов:

· общие - информационные сообщения модуля, ошибки и предупреждения общего характера, не относящиеся конкретно к какому-либо определенному объекту

· сокеты - информация об объектах WinSock

· сетевые клиенты - информация о подключении и обмене данными с управляющими модулями (eBell)

· БД - информация о подключении и сообщениях сервера базы данных

· отладка - внутренние сообщения, отладочная информация. Используется для более подробного мониторинга состояния платы, потоков, линий, задач и т.д.

· устройства - информация от установленных физических устройств (платы, потоки, тайм-слоты)

Таким образом, выбрав необходимый уровень и категорию сообщений можно отследить поведение конкретного объекта, входящего в состав модуля.

Для долговременного мониторинга с возможностью сохранения протокола в файле журнала необходимо выбрать направление записи данных - в файл. Если параметр logAppend файла конфигурации имеет значение YES, то выводимая информация будет добавляться в конец существующего файла журнала, если - NO, то при запуске модуля eBellSrv этот файл будет перезаписан с начала.

Для текущего отображения состояния выбранных для мониторинга объектов можно разрешить вывод данных на экран монитора. С этой целью необходимо установить направление вывода - на экран. После включении данной опции на экране монитора будет создано окно консоли модуля и вся выводимая информация будет доступна для просмотра в этом окне.

Параметр период обновления задач устанавливает период времени в минутах, через который модуль обновляет внутреннюю информацию об активной исходящей задаче. То есть, если, например, в ходе выполнения текущей активной задачи модуль проверяет установки других задач в БД и находит, что активной в данный момент стала другая задача, все соединения по текущей задаче разрываются и начинает выполняться новая задача.

Также, если в процессе функционирования сервера управляющим модулем была создана новая задача, которая должна начать выполняться немедленно, то об этом необходимо сразу сообщить серверу. Иначе изменение статуса задач произойдет только через вышеозначенный интервал времени. Чтобы сделанные изменения вступили в силу немедленно, необходимо, чтобы между управляющим модулем и сервером было установлено соединение. В этом случае оба модуля обмениваются между собой по локальной сети служебными сообщениями и управляющая программа даст непосредственно команду на выполнение модулю eBellSrv.


Настройки

Некоторую часть настроек серверного модуля можно изменять в процессе его работы. Эти изменения вступают в силу немедленно. Об этом было рассказано в предыдущей главе.

Основные настройки загружаются только старте модуля. Все настройки хранятся в файле eBellSrv.ini, где они сгруппированы по назначению в секции. Секция определяется своим именем, заключенным в скобки, например "[SYSTEM]".

Следом за именем секции располагаются строки параметров. Каждый параметр имеет название, вслед за которым через "=" записывается значение параметра. Например, DbConTimeOut=10.

Если необходимо, после значения параметра или в любом другом месте конфигурационного файла можно расположить комментарии. Комментарий - это строка, начинающаяся с символа ";". Строка комментария модулем не читается и не обрабатывается.

Далее подробно рассмотрим все параметры файла конфигурации серверного модуля.


Общие

Секция [SYSTEM] - общие параметры модуля:

· logMode - определяет направление вывода данных журнала:
· FILE - в файл eBellSrv.log
· CONSOLE - на экран монитора
· ALL = FILE+CONSOLE

· logCatLevel - категории выводимых сообщений:
· MESSAGE- сообщения
· WARNING-предупреждения
· ERROR-ошибки
· ALL = MESSAGE+WARNING+ERROR

· logMesLevel - уровень сообщений объектов модуля:
· STATE - общие/системные сообщения
· IOPORTS - сообщения портов ввода/вывода
· PIPES - сообщения программных каналов
· QUEUES - сообщения очередей
· SOCKS - сообщения WinSock
· CLIENTS - сообщения сетевых клиентов
· SQL - сообщения базы данных
· DEBUG - отладочная информация
· UNITS - сообщения от устройств
· ALL - все вышеперечисленные вместе

· logAppend - флаг, определяющий добавлять данные журнала к существующим (YES) или перезаписывать при каждой новой загрузке модуля (NO)

· DbConStr - определяет строку соединения (запуска) с БД. Описание значений параметров, использующихся в строке DbConStr можно найти в документации на СУБД Sybase SQL Anywhere v 7.0.3, которая находтся в папке с установленной СУБД. Часто используемые параметры следующие:
· AUTOSTOP - определяет, выгружать сервер БД после остановки серверного модуля eBellSrv (YES) или нет (NO)
· UID - имя доступа к базе данных. По умолчанию установлено "DBA". Меняется с помощью утилит СУБД (Sybase Central). При изменении этого значения в базе данных необходимо изменить его и данной строке соответственно.
· PWD - пароль доступа к базе данных. По умолчанию установлен "SQL". Меняется с помощью утилит СУБД (Sybase Central). При изменении этого значения в базе данных необходимо изменить его и данной строке соответственно.
· DBN - имя базы данных (в данном случае eBell)
· ENG - имя сервера базы данных (в данном случае eBell). Вообще под одним сервером (ENG) может быть запущено несколько БД (DBN). В этом случае имя сервера БД (ENG) необязательно будет совпадать с именем БД (DBN).
· LINKS - определяет протокол, через который клиент связывается с сервером БД. Используется в случае, если сервер БД и модуль eBellSrv располагаются на разных компьютерах одной ЛВС. В нашем случае значение параметра должно быть TCPIP.
· START - строка, определяющая команду запуска сервера БД. Используется, если сервер БД и серверный модуль находятся на одном компьютере и сервер БД запускается в момент старта eBellSrv. Пример стартовой строки может быть таким: "C:\sybase\SQL Anywhere 7\win32\dbsrv7.exe @c:\msds\olha\db\eBell.cfg", в файле eBell.cfg содержатся параметры запуска сервера БД.

· DbConTimeOut - промежуток времени (в секундах), в течение которого модуль пытается найти или запустить сервер БД и установить с ним соединение. Если в течение указанного времени связь не была установлена, модуль завершает свое выполнение. В случае, если все параметры доступа к БД настроены верно и все необходимые модули присутствуют, а сервер БД не стартует и, как следствие, не запускается серверный модуль, необходимо увеличить значение этого параметра.

· timeRefresh - параметр период обновления задач устанавливает период времени в минутах, через который модуль обновляет внутреннюю информацию об активной исходящей задаче. То есть, если, например, в ходе выполнения текущей активной задачи модуль проверяет установки других задач в БД и находит, что активной в данный момент стала другая задача, все соединения по текущей задаче разрываются и начинает выполняться новая задача. Изменение значения этого параметра доступно из окна установки серверного модуля.

· MyAON - строка, определяющая номер абонента, инициирующего соединение, то есть номер телефона системы оповещения Unit Bell (информация АОН).

· IPPORT - номер IP-порта, на котором ожидает подключения клиентов серверный модуль.

· NUMWP - максимально возможное количество сетевых клиентов, одновременно подключенных к модулю eBellSrv.

· WAV_DIR - определяет поддиректорию относительно текущей (содержащей модуль eBellSrv), в которой располагаются звуковые файлы.


Платы

Секция [BOARD#n] - параметры платы

Содержит параметры для платы компьютерной телефонии "Ольха-9Р" под номером n.

· LOADER - определяет имя файла загрузчика для конкретной сигнализации. Все потоки одной платы будут использовать одну сигнализацию. Файл должен располагаться относительно папки, в которой записаны программные модули комплекса Unit Bell (обычно это папка C:\UNITEL\EBELL).


Потоки

Секция [STREAM#n] - параметры потока E1

Содержит параметры потока E1 с номером n соответствующей платы компьютерной телефонии "Ольха-9Р".

· ON - определяет включен поток (ненулевое значение) или нет (значение равно "0"). Значение по умолчанию - 0.

· SYNCHRO_TYPE - определяет тип сверхкадровой синхронизации. Возможные значения 0 -DoubleFrame и 1 - MultiFrame. Значение по умолчанию - 0.

· SYNCHRO_MODE - определяет источник синхронизации звуковых тайм-слотов. Возможные значения: 0 - синхронизация от платы, 1 - от потока. Значение по умолчанию - 0.

· CODE_TYPE - определяет тип линейного кода. Возможные значения: 0 - HDB3, 1 - AMI. Значение по умолчанию - 0.

· DIAL_MODE - определяет режим набора номера. Возможные значения: 0 - блочный и 1 - перекрывающийся (последовательный). В блочном режиме набора номера все цифры сначала накапливаются в блок, а затем сразу высылаются в сигнальном тайм-слоте. В перекрывающемся режиме цифры номера передаются по мере их набора абонентом на телефонном аппарате, то есть по одной. Значение по умолчанию - 0.

· TIME_OUT_OVRLP - определяет длительность ожидания набора номера в перекрывающемся режиме (в млсек). Значение по умолчанию - 2.

· CALLED_DIGITS - определяет количество цифр вызываемого абонента. Для типа сигнализации Е1 (СТС) R1.5 (2ВСК) возможно установка фиксированного количества цифр для вызова абонента. То есть, если абонент наберет меньшее количество цифр на телефонном аппарате, чем установлено при помощи этой функции, то попытка установки соединения производиться не будет. Необходимо помнить, что для СТС R1.5 количество цифр вызываемого абонента, установленное этой функцией, обязательно должно совпадать с количеством цифр, установленного на АТС, с которой соединена плата. В случае, когда количество цифр различается, возможна некорректная работа платы с АТС и АТС с платой. Значение по умолчанию - 7.

· MFR - определяет тип передачи цифр номера для СТС R1.5.Для типа сигнализации Е1 (СТС) R1.5 (2ВСК) возможно два типа передачи цифр вызываемого номера MFR=1 и Decade=0 (импульсный челнок). Необходимо помнить, что для СТС R1.5 тип передачи цифр номера должен совпадать с режимом, установленным на АТС, с которой соединена плата. В случае, когда количество цифр различается, возможна некорректная работа платы с АТС и АТС с платой, и установление соединения станет невозможным. Значение по умолчанию - 1.

· TONE_DUR - длительность тональной посылки MFR в млсек. Это поле действительно, если поле MFR не равно 0. Может принимать значения от 1 до 255. Значение по умолчанию - 50 млсек.

· PAUSE_DUR - длительность паузы между тональными посылками MFR в млсек. Это поле действительно, если поле MFR не равно 0. Может принимать значения от 1 до 255. Значение по умолчанию - 50 млсек.

· DEFCHAN - определяет установки всех тайм-слотов потока E1 по умолчанию.
· Первый параметр в данной строке: тайм-слот включен (1) или выключен (0).
· Второй параметр: тип канала - 0-входяще/исходящий, 1-входящий, 2-исходящий.
· Третий параметр: тип оборудования на данном тайм-слоте 0-неопределенное оборудование, 1-телефон, 2-FAX.

· CHANNEL#n - определяет установки тайм-слота потока E1 с номером n. Если какого-либо тайм-слота значения параметров не установлены, то принимаются значения по умолчанию, заданные в строке DEFCHAN.


Описание БД

Для информационного обеспечения выполнения комплексом Unit Bell поставленных пред ним задач создана и поддерживается база знаний ebell, включающая базу данных, необходимых для работы системы, и базу правил, применяемых для обработки и получения данных из БД.

Физически база данных представлена файлом на диске с именем eBell.db в формате, поддерживаемом СУБД Sybase SQL Anywhere Studio версии 7.

Доступ к данным осуществляется с помощью языка структурированных запросов (SQL) к системе управления базами данных Sybase SQL Anywhere Studio.

Все данные внутри БД организованы в таблицы. Ниже представлено описание таблиц базы данных и назначение их полей.

Таблица Abonents предназначена для хранения данных об абоненте, используемых для установления соединения и построения голосовых сценариев.
· поле phone - номер телефона абонента. Строка длиной 10 символов.
· поле money - сумма задолженности (счета и т.д.) абонента.
· поле dtPay - дата/время отключения телефона (оплаты и т.д.)
· поле name - наименование абонента (справочная информация)

Используя механизм привлеченных таблиц СУБД Sybase SQL Anywhere Studio версии 7 через установленный в системе ODBC-драйвер можно получить доступ к данным об абоненте в корпоративной БД клиента. В этом случае порядок следования полей в выборке должен сохраняться.

Таблица TypePhrases содержит справочник по типам фраз, используемых в системе.
· Поле type определяет тип фразы (см.Работа с задачами)
· Поле name описывает название типа фразы.

Таблица TypeResults содержит справочник по типам результатов выполненных задач.
· Поле type определяет тип результата (см.Результаты выполнения)
· Поле name описывает название типа результата.

Таблица Tasks содержит информацию о задачах и шаблонах задач.
· idTask - идентификатор задачи
· priority - приоритет задачи
· name - наименование задачи
· dtStart - дата начала выполнения задачи
· dtStop - дата окончания выполнения задачи
· tmStart - время начала выполнения задачи
· tmStop - время окончания выполнения задачи
· count - количество попыток выполнения задачи для конкретного абонента
· range - интервал повторения задачи для конкретного абонента в случае неуспеха предыдущей попытки
· sql - текстовая строка, содержащая SQL-оператор выборки списка абонентов задачи
· type - тип задачи (см. Окно задач)
· enabled - если значение не равно 0 - задача включена, в противном случае - выключена
· DayOfWeek - дни недели, в которые задача активна
· CallNumber - номер доступа к входящей задаче
· confirm - если значение не равно 0, задача требует подтверждения нажатием клавиши KeyPress на тастатуре телефонного аппарата
· complete - если значение не равно 0, задача считается выполненной
· templates - если значение не равно 0, то это шаблон

Таблица TaskPhrases содержит информацию по сценарию голосового обмена для конкретной задачи
· idTask - идентификатор задачи
· sequence - последовательность фразы в списке
· type - тип задачи (см. Окно задач)
· typePhrases - тип фразы (см. Работа с задачами)

Таблица Phrases содержит информацию по установленным в составе комплекса голосовым фразам.
· idPhrases - идентификатор фразы (см. таблицу TypePhrases)
· filename - имя файла фразы (для фразы произвольного типа)
· name - наименование фразы
· visible - признак видимости фразы в окне работы с фразами (см. Ввод фраз)

Таблица Results содержит результаты работы комплекса
· idTask - идентификатор задачи
· phone - номер телефона абонента. Строка длиной 10 символов.
· dtCall - дата/время попытки дозвона (входящего вызова)
· result - результат попытки (см.Результаты выполнения)
· typeTask - тип задачи (см. Окно задач)
· nameTask - наименование задачи


Примеры использования

В данном разделе будут рассмотрены варианты применения системы Unit Bell для решения некоторых конкретных задач.


Телеголосование

Для проведения интерактивных опросов населения комплекс Unit Bell может быть запрограммирован на использование в качестве системы телеголосования.

Все подобные системы опроса населения вне зависимости от широты предметной области и решаемых вопросов (например, необходимость строительства третьего транспортного кольца в Москве, отношение населения к тому или иному кандидату в органы местного самоуправления, обсуждение вопроса о введении двенадцатилетнего среднего образования и т.д.) строятся на схожих принципах и работают по схожим алгоритмам.

В первую очередь при планировании телеголосования необходимо решить будет ли производиться принудительный обзвон потенциальных респондентов или же каждый участник опроса вынужден сам выходить на один из опубликованных номеров доступа с тем, чтобы принять участие в голосовании.

Следует отметить, что второй подход менее "навязчивый" и не вызывает неприятия со стороны населения, так как в опросе люди принимают участие сугубо добровольно. Но в то же время картина может получиться не достаточно полной, так как не отражает довольно значительный пласт электората, не желеющего принимать участие в телеголосовании.

Первый вариант проведения телеголосований позволяет оценить общую картину заинтересованности населения в обсуждаемом вопросе более полно, хотя, может быть, полученные результаты и не совсем удовлетворят инициаторов опроса.

Тем не менее, какой бы подход к проведению опроса не был бы выбран, алгоритм ведения диалога с респондентом всегда включает в себя следующие пункты:

· сообщение цели опроса и необходимой дополнительной информации

· сообщение позиций, по которым проводится опрос

· приглашение выбрать одну из предложенных позиций

· регистрация выбора с дальнейшим сохранением результатов в базе данных

По окончании телеголосования полученные в ходе его проведения данные должны быть обработаны. Следует иметь в виду, что в базе данных помимо результатов, укладывающихся в рамки предложенного выбора ("нажмите кнопку 1", "нажмите кнопку 0" и т.д.) могут оказаться и результаты опроса, имеющие "неопределенный" статус. То есть необходимо также обрабатывать и такие ситуации, как

· абонент положил трубку, не сделав предложенного выбора
· абонент занят
· неответ абонента

Остальные вопросы, связанные с планированием телеголосования, выбором времени суток, дней недели, продолжительности и периодичности опроса, а также тембра голоса, которым озвучиваются голосовые сообщения, должны быть определены до проведения опроса и отмечены в системе с помощью имеющихся в ее распоряжении средств.